Linucentres

Bitàcora d'un instal·lador

 
Alfons
Bitàcora d'un instal·lador
by Alfons Rovira - Friday, 2 September 2011, 6:01 AM
 
Hola xics.

Volia compartir els diferents problemes amb que m'he trobat instal·lant diversos CMS a Linucentres.

1. Moodle

No es pot instal·lar l'última versió 2.2. perquè Linucentres no té l'última versió de Php. Cap problema instal·lem la versió 1.9 i a córrer.

Servisca això de toc d'atenció a Linucentres. Cal actualitzar.


2. Wordpress

Hi ha un script que et genera el mateix CMS per tal de crear l'arxiu wp-config.php, doncs falla. Cal fer-ho a ma a partir del wp-config-sample.php. Res que no es puga fer però potser si no saps això et pots desanimar amb l'intent.


3. eyeOS

He instal·lat la versió 2.5. Aquestos xavals ho fan cada vegada millor però el cas és que sempre falla algo en la instal·lació.

El procés d'instal·lació em donava una errada en una línia d'un arxiu. Docs tot era qüestió d'un apòstrof. Però això no és tot. Resulta que el servidor de Linucentres, desconec la raó, presenta una latencia elevada quan es fa la modificació d'un arxiu javascript i demanes tornar a carregar la pàgina.

El procediment que vaig utilitzar va ser: editar l'arxiu en local i pujar-lo per FTP. En refrescar la pàgina tot seguia igual, fins que em vaig adonar que calia esperar un poc abans de provar altra cosa.

Solucionat això cal tenir aquestes pegues ben presents per tal de no fracasar.


En resum, tot costa una miqueta. Cal tenir paciència i anar fent a poc a poc. Al final sempre arribem a bon port.


Salut
Alfons
Re: Bitàcora d'un instal·lador
by Alfons Rovira - Tuesday, 6 September 2011, 12:12 AM
 
Seguint el fil de coses que instal·lar a Linucentres...

4. TaskFreak

CMS per implementar GTD (metodologia de productivitat) al claustre.

Avantatges: facilitat d'ús, seguiment de tasques, compartició de les mateixes i, el més important una presentació senzilla i clara.

Problemes trobats: cap, soles que per tal de fer que funciona cal configurar l'arxiu config.php que es troba dins de la carpeta include.

http://www.taskfreak.com/

Proveu la demo:

http://demo.taskfreak.com/login.php?PHPSESSID=85glf9k7m06h7m9h4mqmrd6js7

Salut
Alfons
Re: Bitàcora d'un instal·lador
by Alfons Rovira - Tuesday, 6 September 2011, 12:33 AM
 
Salt4

Sí, és veritat Salt4 no funciona amb Libre Office.

No he pugut fer-lo còrrer des d'Ubuntu amb Libre Office.

Tampoc he pugut fer-lo correr des de Mac OS X Snow Leopard.

Però sí he pugut fer-lo córrer des de Debian 6.0 Squeeze. Per fer-ho he hagut d'instal·lar-lo i, després en vista que no funcionava soles cal indicar-li que s'inicie en la versió 2.6 de python.

Com es fa això?

Hi ha un arxiu a /etc/sltsrv (em sembla que es aquest o un molt semblant) El cas és que cal afegir a la primera línea un .6

Ens la trobarem així:

#!python2

Cal deixar-la així

#!python2.6

i a córrer.

Aquesta solució soles funciona per a Debian Squeeze sobre Open Office, però no per a Ubuntu sobre Libre Office.

El desenvolupament de Salt està atorgat a l'equip de Lliurex, a veure si ténen present aquest bug i ho arreglen.

Salut