Fòrum social

socorro no es potentrar en itaca

 
x
socorro no es potentrar en itaca
by francesc juan - Wednesday, 26 November 2014, 1:10 PM
 

Bones,

Justament ara que cal posar les notes no funciona el plugin de flash en firefox en lliurex des del servidor he reinstal·lat el plugin i res. Altres voltes quan ha passat (passa a sovint) hem entrat des de chormium però ara apareix el mateix missatge d'error del plugin de flash.

No se que fer i les notes per posar al centre.

Gràcies si algú em pot ajudar

Pep Pons
Re: socorro no es potentrar en itaca
by Pep Pons - Wednesday, 26 November 2014, 1:44 PM
 

Hola Francesc,

Una pregunta, vols dir. què no funciona el flash en els clients lleugers? per que a mi em pasa el mateix.

x
Re: socorro no es potentrar en itaca
by francesc juan - Wednesday, 26 November 2014, 3:48 PM
 

Exacte Pep, funciona al server i als d'escriptori però el professorat treballa amb lleugers i allí no funciona. Acabe de restaurar la imatge del client per als lleugers i res. Crec recordar que a algú li havia passat el mateix.

Picture of Emilio Martín
Re: socorro no es potentrar en itaca
by Emilio Martín - Wednesday, 26 November 2014, 6:04 PM
 

A mí en el aula de informática el plugin de flash en Mozilla funciona a veces sí y a veces no. En Chromium parece que funciona mejor, pero a veces se bloquean los clientes ligeros y hay que reiniciar.

Desde el SAI me han dicho que el problema se solucionará añadiendo más memoria RAM al servidor y pienso que esa es la razón, porque si no, no entiendo por qué en siete clientes funciona y en otros cinco sale el error del fallo del plugin de flash.

La compraría yo, pero, como el server está en garantía, no puedo abrir el equipo, así que ahí tengo una incidencia abierta desde julio con la recomendación del técnico de que cuando dispongan de la Memoria, nos la hagan llegar.

Si tú puedes, intenta ampliarle la RAM al server y nos dices si se soluciona.

Pep Pons
Re: socorro no es potentrar en itaca
by Pep Pons - Wednesday, 26 November 2014, 7:17 PM
 

Pareix que ès un GRAN problema amb LTSP i firefox

Hi ha que provar altres exploradors, demà si puc provaré:

1. epiphany (en repositoris lliurex)

2. opera (en la web d'opera, és freware)

 

Alfons
Re: socorro no es potentrar en itaca
by Alfons Rovira - Wednesday, 26 November 2014, 11:30 PM
 

Bones.

El tema ja va eixir, ara ho he recordat.

El problema és que Flash per a GNU/Linux sembla estar abandonat, ja que va unes versions per darrere del que es desenvolupa en Windows i Mac.

A Chrome / Chromium-browser ho han solucionat incrustant Flash dins del navegador.

Proveu amb Chromium-browser, cal instal·lar-lo.

sudo apt-get install chromium-browser

Sort

-----------------------
«Admetre que tenim alguna cosa que veure
amb les nostres pérdues és el primer
pas per a la recuperació». — Allan Cox
Compromés pogramador del kernel
de Linux des dels inicis fins al 2009.
x
Re: socorro no es potentrar en itaca
by francesc juan - Thursday, 27 November 2014, 6:51 AM
 

Hola Alfons,

Ja ho he intentat. De fet altres vegades així s'ha solventat però amb chromium dona el mateix error.

És important ja que els ordinadors del professorat són clients lleugers

Picture of Samuel Soriano
Re: socorro no es potentrar en itaca
by Samuel Soriano - Thursday, 27 November 2014, 2:58 PM
 

A nosaltres també ens dona error de vegades, ho solucionem entran en el navegador en la opció de finestra privada, tant en firefox com en chormium. Altra opció seria netejar l'historial de navegador.

Ho comente per que si et dona error en chromium no té res a vorer en la versió de flash ja que chormium porta una incorporada de sèrie...

Flash is dead, llarga vida per a HTML5 xDDDD

Pep Pons
Re: socorro no es potentrar en itaca
by Pep Pons - Thursday, 27 November 2014, 6:19 PM
 

Ara que estem amb LTSP, algú sap com borrar configuracions directament dels arxius LTSP? El problema que tinc es que vaig activar arranc amb login automàtic d'un client per MAC, després ho vaig borrar des del gestor LTSP però el condenat encara arranca automàticment.....

Per a mi que l'equp lliurex és algo terrorrífic ;;;;;;;;;;---)dead

Pep Pons
Re: socorro no es potentrar en itaca
by Pep Pons - Thursday, 27 November 2014, 10:58 PM
 

Solucionat el tema d'autologin per mac:

/var/lib/tftpboot/ltsp/i386/lts.conf

Pep Pons
Re: socorro no es potentrar en itaca
by Pep Pons - Thursday, 4 December 2014, 12:51 PM
 

Al final de tanta prova el client LTSP no arranca. algú sap la sol·lució?

Al posar el login no conecta. Missatge: "No hi ha cap resposta del servidor, s'està reiniciant"

 

alguna ordre per a reconfigurar-ho tot de nou?

x
Re: socorro no es potentrar en itaca
by francesc juan - Thursday, 4 December 2014, 6:04 PM
 

Jo el que vaig fer en una situació semblant és esborrar la imatge del LSTP  i tornar a crear-la. Però continue sense accés a ITACA des de cap navegador i he provat amb tots. Des de lliurex no diuen res. Esperem una solució ja que la gent jha de posar les notes des de sa casa.

Alfons
Re: socorro no es potentrar en itaca
by Alfons Rovira - Monday, 8 December 2014, 8:47 AM
 

Hola Francesc.

Samuel comentava temps enrere que calia netejar la caché del navegador.

Jo entre a Itaca sense problemes des d'Ubuntu 14.04 LTS amb Firefox 34.0

Prova a netejar la caché.

T'envie una captua per tal que pugues veure clar com fer-ho.

Captura de l'escriptori

Fluxbox & Conky forever

Salut

---------------------------------
La pràctica no ens fa perfects,
La pràctica perfecta ens fa perfectes.

Vincent Thomas Lobardi

x
Re: socorro no es potentrar en itaca
by francesc juan - Friday, 12 December 2014, 11:04 AM
 

Adjunte ací la solució que he trobat, o millor dit que m'ha comentat David Montalvà, adjunte el meu post en els foros de lliurex i la seua contribució.

Per si a algí li val en una situació semblant

Post meu

Em conteste a mi mateix perquè he trobat una solució però voldria saber perquè passa això.
He entrat en el meu usuari. He entrat en la carpeta d'inici. He marcat "Mostrar arxius ocults" i he esborrat tots els que tenen un puntet davant (això ho vaig aprendre per solventar problemes amb l'openoffice). He riniciat l'equip lleuger i he tornat a entrar i ara ja puc accedir a itaca. El problema és que els altres 43 mestres o usuaris del centre no saben fer això i poden fer una desfeta i caldria que anar ajo fet-ho un per un a tots els usuaris perquè sols en els que ho faig funciona. Havia provat primer esborrant la carpeta -mozilla soles però no ha funcionat. Vaig un per un esborrant tots els arxius de tots els usuaris ( els del puntet)?

Resposta de David

Hola Francesc,
Quan estem en clients lleugers els fitxers que comencen per "." es guarden al servidor i per tant amb un sol commandament es poden borrar.
Estos fitxers guarden la configuració i preferències tant de les aplicacions com del sistema, per tant al borrar la carpeta .mozilla es borra la configuració d'adreces d'interés, historial, etc.
Estem intentant reproduïr el error per vore quina carpeta/fitxer es la que causa el error, però mentres, si vols fer un borrat genèric de tots eixos fitxes has de seguir estos passos:

1. Entra al servidor amb un usuari promocionat.
2. Obri un terminal
3. Executa:

1 sudo find /home/ -name ".*" -exec rm -rf {} \;



Amb açò hauràs borrat tots els fitxers ocults i possiblement ja pugues accedir a Itaca, si et continua fallant en algun equip que no siga client lleuger hauràs de repetir el procés en eixe equip.

Moltes gràcies per la teua col·laboració.
Salutacions

Picture of Emili Hernández
Re: socorro no es potentrar en itaca
by Emili Hernández - Friday, 12 December 2014, 8:56 PM
 

Ací deixe unes captures dels clients amb els quals es pot utilitzar Itaca.

Complements utilitzats

Versió de java utilitzat

 

Alfons
Re: socorro no es potentrar en itaca
by Alfons Rovira - Saturday, 13 December 2014, 9:35 AM
 

Bones.

@Francesc

Moltes gràcies per la solució automatitzada, ho vaig seguir al correu de mestre a casa, molt interessant.

Vaig aplicar aquesta solució quan, fa anys em van desapareixen menus al Firefox, sembla que es crea de nou si no troba la carpeta oculta.

@Emili

Gràcies per la captura, jo destacaria que cal tenir instal·lat Flash i instal·lat i connectat Java al navegador.

LliureX facilita molt la feina, sols cal resoldre problemes puntuals com aquestos.

Qualsevol torna a l'infern dels sistemes propietaris en tasques repetitives que es solucionen amb un comandament per a tots els usuaris en entorns LliureX.

Salut

---------------
«Simple is better than complex»
The Zen of Python
Picture of Emili Hernández
Re: socorro no es potentrar en itaca
by Emili Hernández - Friday, 9 January 2015, 6:44 PM
 

Al final la solució la ha ficat David Montava en el foro de Lliurex

DAVID MONTALVA FURIO:


Si que hi ha una sol·lució i es configurar el servidor per a que el firefox s'execute als propis clients.


editar sudo vi /var/lib/tftpboot/ltsp/i386/lts.conf

Afegir

---------------------------------------------------------------------------------------------
LOCAL_APPS_EXTRAMOUNTS=/home

LOCAL_APPS = true

LOCAL_APPS_MENU = true

LOCAL_APPS_MENU_ITEMS = firefox,chromium-browser
--------------------------------------------------

--------------------------------------------

Ho he provat i funciona

Jo el que faig es editar el codi del fitxer amb sudo gedit.. i afegisc les línees copiant i pegant. No cla ni reiniciar el servidor.

 

Alfons
Re: socorro no es potentrar en itaca
by Alfons Rovira - Saturday, 10 January 2015, 12:30 PM
 

Gràcies Emili.

Caldria que algú ho posara el Wikimanuals per tal que estiguera més accessible.

Salut

-----------------------

La pràctica no ens fa perfectes,
La pràctica perfecta ens fa perfectes.

Vincent Thomas Lombardi

Salutacions!
Re: socorro no es potentrar en itaca
by Tàfol Nebot gómez - Saturday, 10 January 2015, 1:54 PM
 

Alfons, ja ho he posat jo a wikimanuals. No m'he complicat massa. Si algú vol depurar-lo, sou lliures.

No sé com es fica en la portada.

Salut

Salutacions!
Re: socorro no es potentrar en itaca
by Tàfol Nebot gómez - Friday, 6 February 2015, 6:47 PM
 

Hola, la veritat és que no havia seguit molt aquest fil perquè no ens havia passat el problema. Però ara sí, i no està solucionat.

Tenim a la sala de profes un servidor i 4 clients lleugers amb Lliurex 14. Tot funcionava correcte amb la versió 14.06.0?? Però el divendres passat vam actualitzar a la 14.06.0.86 (Qui me manaria anar a les jornades Lliurex!) I van començar els problemes.

Problema 1. En els clients lleugers no funciona el Flash (versió 11.2.202.440) amb Firefox. Així que no es pot entrar en ITACA. Solució: Hem instal·lat el Chrome i ja funciona (a mi no m'agrada el chrome però què anem a fer). Hem provat tot el que es diu en aquest fil (esborrar els arxius ocults del home de l'usuari, editar el lts.conf) però no va.

Problema 2. En els clients lleugers s'ha desconfigurat el teclat. Ara no va la ñ i tots els símbols no alfanumèrics estan canviats. Solució: Anar a "Apliacions>Administració de Lliurex>Ferramentes del sistema" > "Entrada de text", afegir una font d'entrada (català o espanyol) i ficar-la la primera. El que no he pogut comprovar encara és si aquesta solució és permanent o cal fer-ho cada vegada que entres.

Problema 3. El plugin de Firefox per a obrir PDFs ens bloqueja les fotocopiadores i no es pot imprimir. Solució: descarregar primer el PDF i impromir-lo amb l'Evince o el Adobe Reader.

En fi, us ho dic per a que pugueu preveure estos problemes si algú va a actualitzar.

Salutacions